Welcome to Teampass Feature Requests place

Please consider:

  • using "New Feature" ONLY
  • performing a search before creating a new request
  • voting for the request you would like to see implemented

Thank you for your participation to this project.


Bug report MUST be performed in Github.

Any other topic is performed in Reddit


0

error http 500

adepecheemode 1 year ago 0

Hello, dear friends! could you help me please. i testing solution teampass and when changing the basic settings of the site  teampass - http error 500 and no access in site :(. last version tempass and components. At the same time logging the following errors (attach). Help me please understand the problem. Thank you so match.




0

Migrate from 2.1.24 to latest 2.1.27.10

Alan Lacerda 1 year ago 0

I have a teampass v2.1.24 on a CentOS6 and I am planning to install a new fresh installed CentOS 7 with a brand new teampass installation.

After that i wanna import data from the old one. How is it possible?

0

Folders with only subfolders

Lothar "Husky110" Hoffmann 1 year ago 0

I've got the usecase, that my structure has some folders, which contain only subfolders.

It would be nice if those didn't have a 0 as containing-elements-count, but instead count all subfolders as elements too. 

I kinda start to see elements as nodes whereas an node could contain the data itself or has subnodes. (Frontend-speaking)

0
Completed

On Sharing an Item - The "Email has been sent" message is red. On succes it should be green!

Roru69 1 year ago • updated by Nils Laumaillé 1 year ago 1

When Sharing an item the "Email has been sent" message is red. It triggered me to believe that something went wrong, shouldent all success messages be in Green?

0
Completed

API - list folder by label or list all folders

cbabs 1 year ago • updated by Nils Laumaillé 1 year ago 6

Hey Nils,


Unless I haven't found the right document or I'm stupid(plausible), it seems I can't return folders based on any other value than id and that an id *must* be specified.  Also I don't see anything in the API that allows me to list all folders. 


Either one of these would solve my problem.  If I could list all folders I could put into a JSON dict and loop until I found the 'Label' value and then get the 'id', that would work.  Even better would be if the API could do it for me so I could specify the 'Label'.


I'm using these docs, let me know if this is right.  Thanks for all your work!


Chris


https://teampass.readthedocs.io/en/latest/api/api-read/

0

LDAP and Synology Directory Server

waazdakka 1 year ago 0

Hi ! I'm missing some objects on my Synology Directory Server to fill the LDAP configuration.

I have only the Base DN, Bind DN, FQDN and password for the LDAP server. I'm missing the class to search, User attribute to search, and maybe some other elements I don't know for now.
How could I fill all fields to complete the configuration ?

Thanks !




0
Declined

Undefined index: key in /teampass/items.import.php on line 21

Renan Arcanjo 1 year ago • updated by Telmo Rodrigues 1 year ago 2

 Undefined index: key in /teampass/items.import.php on line 21

0
Declined

Need help with the API

angelan96 1 year ago • updated by Nils Laumaillé 1 year ago 3

I need some help please, I´m trying to access teampass data via API using a web browser.

The problem is that I´m doing something wrong cause I receive 404 error, could you tell me which is the path to teampass API?

0
Declined

LDAP and local accounts

Konrad Burkowski 1 year ago • updated 12 months ago 2

My TeamPass is LDAP connected (AD) and logons of AD users works fine.
But I want to add the next local admin account (like an account "admin" is and I can do local login with it). After creating new user (admin_kb7777) I can't login, beacuse there is no such account at my ldap (and I don't want to add it to my AD; it has to be local teampass account).

0
Declined

show only custom fields filled

maiconstedille 1 year ago • updated by Nils Laumaillé 1 year ago 1
Hello,
was using version 2.1.27 and the custom fields of the objects were presented only those that were filled. I updated to version 2.1.28 and noticed that now we have the option to mask the custom fields, which is very good. But now even the empty custom fields are presented in the objects. Is it possible to show only those that are filled in objects?
It would be great if we could keep the new feature of 2.1.28 (custom fields masked), and also show only the custom fields that are filled.